Linux(xUbuntu18.04)安装VMware workstation15.1 解决报错:Before you can runVMware

1.官网下载安装包

https://www.vmware.com/products/workstation-pro/workstation-pro-evaluation.html

2.安装

  • VMware-Workstation-Full-15.5.0-14665864.x86_64.bundle
    在这里插入图片描述
  • 进入 bundle 文件所在目录(便于操作),给 bundle 文件添加执行权限:

sudo chmod +x VMware-Workstation-Full-15.5.0-14665864.x86_64.bundle

  • 添加好执行权限之后就是安装了。在终端内执行以下命令启动安装流程:

sudo ./VMware-Workstation-Full-15.5.0-14665864.x86_64.bundle

  • 在应用菜单就可以看到VMware了
  • 如果你能够正常打开,就可以直接跳到文末复制激活密钥了.

填坑

1.缺少GCC环境

apt install gcc

2.报错 Before you can runVMware, several modules must be compiled and load

参考链接:https://jingyan.baidu.com/article/da1091fb34fc84027849d61e.html

  • 下载补丁文件vmnet-3.19.patch

http://pan.baidu.com/s/1sj4uWFF 提取码:a7wq

  • cd /usr/lib/vmware/modules/source

  • sudo tar -xf vmnet.tar

  • sudo patch -p0 -i /tmp/vmnet-3.19.patch

tmp/vmnet-3.19.patch 选择你补丁文件的目录

  • sudo tar -cf vmnet.tar vmnet-only

  • rm -rf vmnet-only

  • vmware-modconfig --console --install-all

  • 我执行到最后一步时,报错,又查到需要安装Build Essential,

  • Built Essential包含对编译Ubuntu二进制安装包所需的所有包的引用。

  • sudo apt install build-essential

  • 到这里,终于正常打开了

激活密钥

  • ZC10K-8EF57-084QZ-VXYXE-ZF2XF

  • UF71K-2TW5J-M88QZ-8WMNT-WKUY4

  • AZ7MK-44Y1J-H819Z-WMYNC-N7ATF

  • CU702-DRD1M-H89GP-JFW5E-YL8X6

  • YY5EA-00XDJ-480RP-35QQV-XY8F6

  • VA510-23F57-M85PY-7FN7C-MCRG0


在这里插入图片描述

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 技术黑板 设计师:CSDN官方博客 返回首页